Page 1 of 1

Troubleshooting a Colt Excallibur

Posted: 20 May 2020, 13:20
by 29LV145
Hey all

Hope someone can point me in the right direction to get this radio back up and running please. Rig has been sitting in the attic for years but decided to bring it down and start using it again when I'm not doing the needful on conference calls for work.

Board is a PTBM125A4X

The rig does not transmit or receive, no change in sound when I adjust the volume, squelch doesn't close as expected. There is no change in received sound when I switch modes.

Someone suggested elsewhere to look at Q36 which might have been the problem so I swapped it out for a TIP120 but still no change in the issue, I measured the volts on the PLL but most of the readings seemed to be around 0.6v

Any pointers on what I could check next please if its something that could be fixed without shipping it over to a rig doctor here in Ireland?

Maybe the VCO has failed? The test point ( TP3 ) next to the Orange VCO showed 5.4V when I metered it last.

Thanks in advance for any help

Cheers Andy 145 Ireland.

Re: Troubleshooting a Colt Excallibur

Posted: 20 May 2020, 15:56
by Mitch
Have you got the Cybernet Export Manual? There's an online copy here if you need one. I'd start by checking all the voltages are right, 9v, rx volts, pll volts etc. and check the zener diodes too, it's a bit difficult to know without seeing it though. It could be electrolitic caps gone fubar, or thru board plating fault, or dry joint even. There's a lot that can go wrong, but it could be something simple. Good luck with it.

Re: Troubleshooting a Colt Excallibur

Posted: 20 May 2020, 16:16
by 29LV145
Hi Mitch

Thanks for the link and reply, I found that on my googling around - I'll start checking voltages etc, worse case if its not simple I'll ship it off to someone around here to take a look.

Re: Troubleshooting a Colt Excallibur

Posted: 24 May 2020, 16:13
by 29LV145
Update from my side...

Changed Q36 and D55 - white noise is getting louder when increasing the volume and changes when switching modes. Still no receive and there is some RF on transmit but not having a frequency counter to see where it is actually transmitting isnt helpful.

I'm wondering if the next issue is a bad VCO - pin6 on PLL02A is 2.3V and pin5 is 5.73V - suggesting no lock?

If I tune a HF radio to 19.880/20.105/20.330/20.555 ( offset oscillators? ) for the different bands I can hear a signal, turning off the radio the signal is gone, if I move the tune knob. the signal moves.

Does this sound like a bad VCO?

Re: Troubleshooting a Colt Excallibur

Posted: 24 May 2020, 22:09
by Mitch
Have you checked for 10.240Mhz? There's a capacitor there that can go bad. VCO's can go too, Spectrum do a good replacement.

Re: Troubleshooting a Colt Excallibur

Posted: 25 May 2020, 07:14
by 29LV145
Not yet - need to order myself a frequency counter to start sniffing for RF correctly - again thanks for the reply Mitch.