President Grant PLL/VCO/10.240 oscillator Problem

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
Post Reply
User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 10 Sep 2018, 15:32

Hi friends, i have a strange problem with a PC-999AB Grant. Sometimes the ref osci 10.240 stops working. Swaped all electrolytic caps, swaped C108/109, swaped the xtal.
If i do some tests with the PLL at pin 8, the osci starts working again for some time. VCO voltage is ok, but drops down to 2,0v when osci stops working.
Any ideas? PLL chip?

73, Ralf

User avatar
cb4ever104
Veteran
Veteran
Posts: 4544
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by cb4ever104 » 10 Sep 2018, 17:30

Hi Ralf .

Yeah . I'd try swapping out the 8719 PLL and see what happens .

Sammy
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 10 Sep 2018, 20:53

Yes Sammy, hope that it is the PLL. Hope tomorrow the replacement will arrive. A friend of mine has two MB8719 in stock. The voltage is to low at Pin7/8. Pin6 is low, so VCO is not locked. Nearly all voltages at the PLL are to low...compared to my working Grant. But.Vdd is ok at Pin9 with 8v. Sometimes the 10.240 osci starts working, Then voltage at Pin7/8 is round about 2,8v. But suddenly it drops down to 2,4v and osci is not working.
Will see...
Last edited by 13EL121 on 10 Sep 2018, 21:00, edited 2 times in total.

User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 10 Sep 2018, 20:58

The binary adders are ok for shure. Maybe a shorted cap has killed the PLL. There were some grey YEC 10v caps that were shorted. The 100uf in the VCO area was one of them.

User avatar
KlondikeMike
Regular
Regular
Posts: 73
Joined: 06 Jan 2014, 03:59
Call Sign: 9WR2000
Location: Edmonton, Alberta, Canada
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by KlondikeMike » 10 Sep 2018, 22:18

13EL121 wrote:
10 Sep 2018, 20:58
... There were some grey YEC 10v caps that were shorted.
Yikes! Most likely. There are many of those YEC 10v caps in the HR2510 as well.
9WR2000

User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 11 Sep 2018, 19:58

Indeed. The grey YEC 10v ones are a main Problem of 20-30 years old Uniden radios. The blue caps from Rubycon are not affected. But the grey ones have to leave all my radios.

User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 13 Sep 2018, 17:07

Update: PLL swaped. Radio seems to work fine now. All voltages at the PLL pins are now in specifications. Maybe a shorted cap has blown the PLL.

User avatar
cb4ever104
Veteran
Veteran
Posts: 4544
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by cb4ever104 » 13 Sep 2018, 18:24

Could be Ralf . I've had a few Presidents with shorted caps around that area . Glad you got it sorted .

Sammy
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

User avatar
13EL121
Super Member
Super Member
Posts: 378
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PLL/VCO/10.240 oscillator Problem

Post by 13EL121 » 16 Sep 2018, 21:12

Radio works great now. No faults anymore. Did a full recap as there were the grey YEC caps inside. The new chinese 105 degrees JWCO and KY caps will do the job for the next one or two decades...
These caps are also in the new President radios. So they are not too bad for the money i think. :D

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests